R2CORBA version 1.4.1 released. Includes Ruby Gem support!

R2CORBA version 1.4.1 has been released. This is the first version providing an R2CORBA Ruby Gem and distribution through rubygems.org.
Added by Martin Corino about 4 years ago

R2CORBA version 1.4.1 has been released.

This version implements the following changes:

  • Replacement of the 'old’ setup.rb based build system by a Rake based build system
  • Added support for distribution/installation of R2CORBA as a Ruby Gem
  • Added new r2corba tool script. Currently provides support for running included regression tests after gem installation.
  • all fixes for OSPortal issues
  • tested support for the latest releases of Ruby, JRuby, TAO and JacORB

This release has been tested on Windows 32bit (MRI 1.8.7, 1.9.3 and 2.0.0; JRuby) and 64bit (MRI 2.0.0) as well as on Linux 64bit (MRI 1.8.7, 1.9.3 and 2.0.0; JRuby).

IMPORTANT: Following the EOL of Ruby 1.8.7 this release will be the last release supporting MRI 1.8.7.


Comments